IonCube Loader is a software instrument, which is required to run files which are encoded with ionCube PHP Encoder. The latter is an app that is used to make PHP code human unreadable, as a way to protect it from reverse engineering and / or not authorized use. Many script-driven applications, particularly message boards, cms and electronic commerce solutions are protected with ionCube PHP Encoder, therefore if you get a script and you find that ionCube is among the website hosting environment requirements, you should make sure that your website hosting server has the tool pre-installed. Although it's not that difficult to install it if you have your own server, it is almost impossible to do that on a shared web hosting server for the reason that the PHP environment shall have to be precompiled and all the clients on the server will be affected.

IonCube in Cloud Hosting

IonCube Loader comes with all cloud hosting packages that we supply, so if you require it to install and execute some script app which requires it, you can enable it with a click from the Advanced area of the Hepsia Control Panel. As you are able to switch the PHP release which is active for your account from the same section, you'll need to activate the instrument for every new version that you set. If you're more skillful, you will be able to employ a php.ini file in a domain or subdomain folder and set the PHP version and the status of ionCube Loader for that particular site only, without affecting the whole account. Thus you can run both new and older script apps for multiple sites in the same account - a thing that you won't be able to do with various other web hosting suppliers out there.

IonCube in Semi-dedicated Hosting

Because all the semi-dedicated server accounts are created on our advanced cluster platform and ionCube Loader is available on it, you'll be able to use any script application which requires this tool so as to run effectively. With several clicks in your Hepsia website hosting Control Panel you can activate or deactivate ionCube for the PHP version which is currently active for your account. Since we support multiple versions of PHP at the same time, you will have to do that each and every time you move to a different release, and if you revert back to a release which you have already used, our system will remember your preference and ionCube Loader will already be activated. When you have a couple of sites inside the same account and they need different versions of PHP, you will be able to create a php.ini file in each domain folder and with several lines of program code you will be able to define both the PHP release as well as the status of ionCube regardless of what is selected for the hosting account altogether.